const regex = /\/\*(?!(\<\!\[CDATA\[)|(\]\]>))(.*?)\*\//gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*(?!(\\<\\!\\[CDATA\\[)|(\\]\\]>))(.*?)\\*\\\/', 'gs')
const str = `<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/lib.js?<?php echo CACHEBUST; ?>"></script>
<?php /*<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/prod.js.php?<?php echo CACHEBUST; ?>"></script> */ ?>
<script type="text/javascript">
/*<![CDATA[*/
updateBodyClassContext();
cookieSetContext();
/* Run code on page load */
addEvent(window, 'load', function()
{
/**
*
* Example comment inside of
* CDATA
*
*/
document.getElementById('emailm').focus();
if (location.href.indexOf('prereg=2') > -1) document.getElementById('prereg_email').focus();
addEvent(document.getElementById('prereg_form'), 'submit', function(e)
{
var e = (e) ? e : window.event,
regex_email = /^([a-z0-9])(([-a-z0-9._])*([a-z0-9_-]))*@([a-z0-9])(([a-z0-9-])*([a-z0-9]))+(\\.([a-z0-9])([-a-z0-9-])?([a-z0-9])+)+\$/i;
if (this.prereg_email.value == ''
|| !regex_email.test(this.prereg_email.value))
{
this.prereg_email.focus();
stopEvent(e);
}
});
});
/*]]>*/
</script>
/* another comment for good measure */
/*and another
*/
/*another*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}