# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*(?!(\<\!\[CDATA\[)|(\]\]>))(.*?)\*\/"
test_str = ("<script type=\"text/javascript\" src=\"//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/lib.js?<?php echo CACHEBUST; ?>\"></script>\n"
"<?php /*<script type=\"text/javascript\" src=\"//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/prod.js.php?<?php echo CACHEBUST; ?>\"></script> */ ?>\n"
"<script type=\"text/javascript\">\n"
"/*<![CDATA[*/ \n"
"updateBodyClassContext(); \n"
"cookieSetContext();\n\n"
"/* Run code on page load */\n"
"addEvent(window, 'load', function() \n"
"{\n"
" /**\n"
" *\n"
" * Example comment inside of \n"
" * CDATA\n"
" *\n"
" */\n"
" document.getElementById('emailm').focus();\n"
" if (location.href.indexOf('prereg=2') > -1) document.getElementById('prereg_email').focus();\n"
" addEvent(document.getElementById('prereg_form'), 'submit', function(e)\n"
" {\n"
" var e = (e) ? e : window.event, \n"
" regex_email = /^([a-z0-9])(([-a-z0-9._])*([a-z0-9_-]))*@([a-z0-9])(([a-z0-9-])*([a-z0-9]))+(\\.([a-z0-9])([-a-z0-9-])?([a-z0-9])+)+$/i;\n"
" if (this.prereg_email.value == '' \n"
" || !regex_email.test(this.prereg_email.value))\n"
" {\n"
" this.prereg_email.focus();\n"
" stopEvent(e);\n"
" }\n"
" });\n"
"}); \n"
"/*]]>*/\n"
"</script>\n"
"/* another comment for good measure */\n"
"/*and another\n"
"*/\n"
"/*another*/")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.