use strict;
my $str = '<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/lib.js?<?php echo CACHEBUST; ?>"></script>
<?php /*<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/prod.js.php?<?php echo CACHEBUST; ?>"></script> */ ?>
<script type="text/javascript">
/*<![CDATA[*/
updateBodyClassContext();
cookieSetContext();
/* Run code on page load */
addEvent(window, \'load\', function()
{
/**
*
* Example comment inside of
* CDATA
*
*/
document.getElementById(\'emailm\').focus();
if (location.href.indexOf(\'prereg=2\') > -1) document.getElementById(\'prereg_email\').focus();
addEvent(document.getElementById(\'prereg_form\'), \'submit\', function(e)
{
var e = (e) ? e : window.event,
regex_email = /^([a-z0-9])(([-a-z0-9._])*([a-z0-9_-]))*@([a-z0-9])(([a-z0-9-])*([a-z0-9]))+(\\.([a-z0-9])([-a-z0-9-])?([a-z0-9])+)+$/i;
if (this.prereg_email.value == \'\'
|| !regex_email.test(this.prereg_email.value))
{
this.prereg_email.focus();
stopEvent(e);
}
});
});
/*]]>*/
</script>
/* another comment for good measure */
/*and another
*/
/*another*/';
my $regex = qr/\/\*(?!(\<\!\[CDATA\[)|(\]\]>))(.*?)\*\//sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}