import Foundation
let pattern = #"\/\*(?!(\<\!\[CDATA\[)|(\]\]>))(.*?)\*\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/lib.js?<?php echo CACHEBUST; ?>"></script>
<?php /*<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/prod.js.php?<?php echo CACHEBUST; ?>"></script> */ ?>
<script type="text/javascript">
/*<![CDATA[*/
updateBodyClassContext();
cookieSetContext();
/* Run code on page load */
addEvent(window, 'load', function()
{
/**
*
* Example comment inside of
* CDATA
*
*/
document.getElementById('emailm').focus();
if (location.href.indexOf('prereg=2') > -1) document.getElementById('prereg_email').focus();
addEvent(document.getElementById('prereg_form'), 'submit', function(e)
{
var e = (e) ? e : window.event,
regex_email = /^([a-z0-9])(([-a-z0-9._])*([a-z0-9_-]))*@([a-z0-9])(([a-z0-9-])*([a-z0-9]))+(\.([a-z0-9])([-a-z0-9-])?([a-z0-9])+)+$/i;
if (this.prereg_email.value == ''
|| !regex_email.test(this.prereg_email.value))
{
this.prereg_email.focus();
stopEvent(e);
}
});
});
/*]]>*/
</script>
/* another comment for good measure */
/*and another
*/
/*another*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)