package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\\cref\{(fig:\d+)\})(?:[^.]+?(?:\\cref\{(fig:\d+)\}))+`)
var str = `Aaa \cref{fig:1}. Bbb \cref{fig:2} bbb \cref{fig:3}. Ccc \cref{fig:4}. Ddd \cref{fig:5} ddd \cref{fig:6} ddd \cref{fig:7}. Eee \cref{fig:5} ddd \cref{fig:6} eee \cref{fig:7} eeeee \cref{fig:89} .
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}