import re
regex = re.compile(r"(?:\\cref\{(fig:\d+)\})(?:[^.]+?(?:\\cref\{(fig:\d+)\}))+")
test_str = ("Aaa \\cref{fig:1}. Bbb \\cref{fig:2} bbb \\cref{fig:3}. Ccc \\cref{fig:4}. Ddd \\cref{fig:5} ddd \\cref{fig:6} ddd \\cref{fig:7}. Eee \\cref{fig:5} ddd \\cref{fig:6} eee \\cref{fig:7} eeeee \\cref{fig:89} .\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")