// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\\cref\{(fig:\d+)\})(?:[^.]+?(?:\\cref\{(fig:\d+)\}))+").unwrap();
let string = "Aaa \\cref{fig:1}. Bbb \\cref{fig:2} bbb \\cref{fig:3}. Ccc \\cref{fig:4}. Ddd \\cref{fig:5} ddd \\cref{fig:6} ddd \\cref{fig:7}. Eee \\cref{fig:5} ddd \\cref{fig:6} eee \\cref{fig:7} eeeee \\cref{fig:89} .
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}