re = /(?:\\cref\{(fig:\d+)\})(?:[^.]+?(?:\\cref\{(fig:\d+)\}))+/
str = 'Aaa \\cref{fig:1}. Bbb \\cref{fig:2} bbb \\cref{fig:3}. Ccc \\cref{fig:4}. Ddd \\cref{fig:5} ddd \\cref{fig:6} ddd \\cref{fig:7}. Eee \\cref{fig:5} ddd \\cref{fig:6} eee \\cref{fig:7} eeeee \\cref{fig:89} .
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end