const regex = new RegExp('(?:\\\\cref\\{(fig:\\d+)\\})(?:[^.]+?(?:\\\\cref\\{(fig:\\d+)\\}))+', 'g')
const str = `Aaa \\cref{fig:1}. Bbb \\cref{fig:2} bbb \\cref{fig:3}. Ccc \\cref{fig:4}. Ddd \\cref{fig:5} ddd \\cref{fig:6} ddd \\cref{fig:7}. Eee \\cref{fig:5} ddd \\cref{fig:6} eee \\cref{fig:7} eeeee \\cref{fig:89} .
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}