import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>(\\s| |<\\/?\\s?br\\s?\\/?>)*<\\/?p>";
final String string = "<div class=\"copy_box\"><p></p>\n"
+ "<p class=\"keepme\">Nam blandit orci vel lorem rhoncus, eu ornare mauris tempor. Cras et volutpat est, eget tempus lectus. In placerat felis a convallis dapibus.</p>\n"
+ "<p class=\"keepme\">Aliquam viverra auctor mollis. Aliquam ornare urna non nisl cursus laoreet. Fusce sed eleifend turpis, pretium lectus. Proin eleifend scelerisque lacus id eleifend. Aenean luctus est et tristique convallis. In blandit urna.</p>\n"
+ "<p>\n"
+ "</p></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}