#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[(code|php)][^[]*\[/\1](*SKIP)(*F)|:\("
Local $sString = "There is a sad face somew:(here inside this text." & @CRLF & _
"" & @CRLF & _
"[code]There is a sad face somew" & @CRLF & _
":(" & @CRLF & _
"here inside this text." & @CRLF & _
"[/code]" & @CRLF & _
"" & @CRLF & _
"[php]There is a sad face somew:(here inside this text.[/php]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")