re = /\[(code|php)][^[]*\[\/\1](*SKIP)(*F)|:\(/i
str = 'There is a sad face somew:(here inside this text.
[code]There is a sad face somew
:(
here inside this text.
[/code]
[php]There is a sad face somew:(here inside this text.[/php]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end