using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(code|php)][^[]*\[/\1](*SKIP)(*F)|:\(";
string input = @"There is a sad face somew:(here inside this text.
[code]There is a sad face somew
:(
here inside this text.
[/code]
[php]There is a sad face somew:(here inside this text.[/php]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}