const regex = new RegExp('\\[(code|php)][^[]*\\[/\\1](*SKIP)(*F)|:\\(', 'gi')
const str = `There is a sad face somew:(here inside this text.
[code]There is a sad face somew
:(
here inside this text.
[/code]
[php]There is a sad face somew:(here inside this text.[/php]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}