$re = '~\[(code|php)][^[]*\[/\1](*SKIP)(*F)|:\(~i';
$str = 'There is a sad face somew:(here inside this text.
[code]There is a sad face somew
:(
here inside this text.
[/code]
[php]There is a sad face somew:(here inside this text.[/php]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);