#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"
Local $sString = "Received: from [192.168.1.1] (n11649196059.netvigator.com. [192.168.1.1])" & @CRLF & _
" #by mx.google.com with ESMTPSA id w12sm4743917pbs.68.2015.06.04.16.21.51" & @CRLF & _
" #for <franz.klammer@gmail.com>" & @CRLF & _
" #(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);" & @CRLF & _
" #Thu, 04 Jun 2015 16:21:52 -0700 (PDT)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")