import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})";
final String string = "Received: from [192.168.1.1] (n11649196059.netvigator.com. [192.168.1.1])\n"
+ " #by mx.google.com with ESMTPSA id w12sm4743917pbs.68.2015.06.04.16.21.51\n"
+ " #for <franz.klammer@gmail.com>\n"
+ " #(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);\n"
+ " #Thu, 04 Jun 2015 16:21:52 -0700 (PDT)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}