const regex = /(([a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})', 'gm')
const str = `Received: from [192.168.1.1] (n11649196059.netvigator.com. [192.168.1.1])
#by mx.google.com with ESMTPSA id w12sm4743917pbs.68.2015.06.04.16.21.51
#for <franz.klammer@gmail.com>
#(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
#Thu, 04 Jun 2015 16:21:52 -0700 (PDT)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}