$re = '/(([a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/m';
$str = 'Received: from [192.168.1.1] (n11649196059.netvigator.com. [192.168.1.1])
#by mx.google.com with ESMTPSA id w12sm4743917pbs.68.2015.06.04.16.21.51
#for <franz.klammer@gmail.com>
#(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
#Thu, 04 Jun 2015 16:21:52 -0700 (PDT)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);