use strict;
my $str = 'Received: from [192.168.1.1] (n11649196059.netvigator.com. [192.168.1.1])
#by mx.google.com with ESMTPSA id w12sm4743917pbs.68.2015.06.04.16.21.51
#for <franz.klammer@gmail.com>
#(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
#Thu, 04 Jun 2015 16:21:52 -0700 (PDT)';
my $regex = qr/(([a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}