#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?!especifica\b)(\w+\b)(\s+)\b(?!especifica\b)"
Local $sString = "especifica especifica" & @CRLF & _
"otra especifica" & @CRLF & _
"especifica otra" & @CRLF & _
"otra otra" & @CRLF & _
"" & @CRLF & _
"especificamente especifica" & @CRLF & _
"especifica especificamente" & @CRLF & _
"especificamente especificamente" & @CRLF & _
"" & @CRLF & _
"inespecifica especifica" & @CRLF & _
"especifica inespecifica" & @CRLF & _
"inespecifica inespecifica"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")