# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?!especifica\b)(\w+\b)(\s+)\b(?!especifica\b)"
test_str = ("especifica especifica\n"
"otra especifica\n"
"especifica otra\n"
"otra otra\n\n"
"especificamente especifica\n"
"especifica especificamente\n"
"especificamente especificamente\n\n"
"inespecifica especifica\n"
"especifica inespecifica\n"
"inespecifica inespecifica")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.