using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!especifica\b)(\w+\b)(\s+)\b(?!especifica\b)";
string input = @"especifica especifica
otra especifica
especifica otra
otra otra
especificamente especifica
especifica especificamente
especificamente especificamente
inespecifica especifica
especifica inespecifica
inespecifica inespecifica";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}