$re = '/\b(?!especifica\b)(\w+\b)(\s+)\b(?!especifica\b)/i';
$str = 'especifica especifica
otra especifica
especifica otra
otra otra
especificamente especifica
especifica especificamente
especificamente especificamente
inespecifica especifica
especifica inespecifica
inespecifica inespecifica';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);