import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!especifica\\b)(\\w+\\b)(\\s+)\\b(?!especifica\\b)";
final String string = "especifica especifica\n"
+ "otra especifica\n"
+ "especifica otra\n"
+ "otra otra\n\n"
+ "especificamente especifica\n"
+ "especifica especificamente\n"
+ "especificamente especificamente\n\n"
+ "inespecifica especifica\n"
+ "especifica inespecifica\n"
+ "inespecifica inespecifica";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}