using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}\w{4}\.\d{1,3})";
string substitution = @"\1,";
string input = @" 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}