package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4}\w{4}\.\d{1,3})`)
var str = []byte(` 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25`)
var substitution = []byte("\1,")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}