const regex = /(\d{4}\w{4}\.\d{1,3})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}\\w{4}\\.\\d{1,3})', '')
const str = ` 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25`;
const subst = `\1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);