re = /(\d{4}\w{4}\.\d{1,3})/
str = ' 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25'
subst = '\\1,'
result = str.sub(re, subst)
# Print the result of the substitution
puts result