#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:v=|be\/|ed\/)(.*?)(?:$|&)"
Local $sString = "https://www.youtube.com/watch?v=OWoQpzdB5gs&feature=youtu.be"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")