package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:v=|be\/|ed\/)(.*?)(?:$|&)`)
var str = `https://www.youtube.com/watch?v=OWoQpzdB5gs&feature=youtu.be`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}