re = /(?:v=|be\/|ed\/)(.*?)(?:$|&)/
str = 'https://www.youtube.com/watch?v=OWoQpzdB5gs&feature=youtu.be'
# Print the match result
str.match(re) do |match|
puts match.to_s
end