using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:v=|be\/|ed\/)(.*?)(?:$|&)";
string input = @"https://www.youtube.com/watch?v=OWoQpzdB5gs&feature=youtu.be";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}