$re = '/(?:v=|be\/|ed\/)(.*?)(?:$|&)/';
$str = 'https://www.youtube.com/watch?v=OWoQpzdB5gs&feature=youtu.be';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);