# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^wdslider($|[0-9]+$|(_amu|_gms|_gti|_gov)[0-9]+$|(_cc|_gold|_preview)$)//;t' <<< "wdslider_cc
"