$re = '/^wdslider($|[0-9]+$|(_amu|_gms|_gti|_gov)[0-9]+$|(_cc|_gold|_preview)$)/';
$str = 'wdslider_cc
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;