package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^wdslider($|[0-9]+$|(_amu|_gms|_gti|_gov)[0-9]+$|(_cc|_gold|_preview)$)`)
var str = []byte(`wdslider_cc
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}