re = /^wdslider($|[0-9]+$|(_amu|_gms|_gti|_gov)[0-9]+$|(_cc|_gold|_preview)$)/
str = 'wdslider_cc
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result