using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^wdslider($|[0-9]+$|(_amu|_gms|_gti|_gov)[0-9]+$|(_cc|_gold|_preview)$)";
string substitution = @"";
string input = @"wdslider_cc
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}