# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[-_]?[0-9]+x[0-9]+)+//g;t' <<< "http://url.com/0304-parapente-lagoon-Reunion-96x64.jpg
http://url.com/0304-parapente-lagoon-Reunion-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion-1500x1000.jpg
http://url.com/0304-parapente-lagoon-Reunion-1280x840-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion.jpg
http://url.com/520963918_960x540.jpg"