// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[-_]?[0-9]+x[0-9]+)+").unwrap();
let string = "http://url.com/0304-parapente-lagoon-Reunion-96x64.jpg
http://url.com/0304-parapente-lagoon-Reunion-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion-1500x1000.jpg
http://url.com/0304-parapente-lagoon-Reunion-1280x840-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion.jpg
http://url.com/520963918_960x540.jpg";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}