import Foundation
let pattern = #"(?:[-_]?[0-9]+x[0-9]+)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://url.com/0304-parapente-lagoon-Reunion-96x64.jpg
http://url.com/0304-parapente-lagoon-Reunion-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion-1500x1000.jpg
http://url.com/0304-parapente-lagoon-Reunion-1280x840-960x640.jpg
http://url.com/0304-parapente-lagoon-Reunion.jpg
http://url.com/520963918_960x540.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)