#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img.*?src=\\"(.+?)\\""
Local $sString = "ink = "<a href=\"https://www.abc.gov/asd/asdfg/bill/bill-a\">H.R.11461</a>"" & @CRLF & _
"ink = "<a href=\"https://www.abc.gov/asd/asdfg/bill/bill-b\">H.R.11461</a>"" & @CRLF & _
"ink = "<img class='image-small' src=\"https://www.abc.gov/asd/asdfg/bill/bill-a\">"" & @CRLF & _
"ink = "<img class='image-large' src=\"https://www.abc.gov/asd/asdfg/bill/bill-b\" id='image'>"" & @CRLF & _
"ink = "<iframe class='ifram' src=\"http://www.xyzabc.com\"></iframe>"" & @CRLF & _
"ink = "<iframe src=\"http://www.xyzabc.com\" id='fram-1'></iframe>""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")