$re = '/<img.*?src=\\\\"(.+?)\\\\"/';
$str = 'ink = "<a href=\\"https://www.abc.gov/asd/asdfg/bill/bill-a\\">H.R.11461</a>"
ink = "<a href=\\"https://www.abc.gov/asd/asdfg/bill/bill-b\\">H.R.11461</a>"
ink = "<img class=\'image-small\' src=\\"https://www.abc.gov/asd/asdfg/bill/bill-a\\">"
ink = "<img class=\'image-large\' src=\\"https://www.abc.gov/asd/asdfg/bill/bill-b\\" id=\'image\'>"
ink = "<iframe class=\'ifram\' src=\\"http://www.xyzabc.com\\"></iframe>"
ink = "<iframe src=\\"http://www.xyzabc.com\\" id=\'fram-1\'></iframe>"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);