use strict;
my $str = 'ink = "<a href=\\"https://www.abc.gov/asd/asdfg/bill/bill-a\\">H.R.11461</a>"
ink = "<a href=\\"https://www.abc.gov/asd/asdfg/bill/bill-b\\">H.R.11461</a>"
ink = "<img class=\'image-small\' src=\\"https://www.abc.gov/asd/asdfg/bill/bill-a\\">"
ink = "<img class=\'image-large\' src=\\"https://www.abc.gov/asd/asdfg/bill/bill-b\\" id=\'image\'>"
ink = "<iframe class=\'ifram\' src=\\"http://www.xyzabc.com\\"></iframe>"
ink = "<iframe src=\\"http://www.xyzabc.com\\" id=\'fram-1\'></iframe>"';
my $regex = qr/<img.*?src=\\"(.+?)\\"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}