# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img.*?src=\\\"(.+?)\\\""
test_str = ("ink = \"<a href=\\\"https://www.abc.gov/asd/asdfg/bill/bill-a\\\">H.R.11461</a>\"\n"
"ink = \"<a href=\\\"https://www.abc.gov/asd/asdfg/bill/bill-b\\\">H.R.11461</a>\"\n"
"ink = \"<img class='image-small' src=\\\"https://www.abc.gov/asd/asdfg/bill/bill-a\\\">\"\n"
"ink = \"<img class='image-large' src=\\\"https://www.abc.gov/asd/asdfg/bill/bill-b\\\" id='image'>\"\n"
"ink = \"<iframe class='ifram' src=\\\"http://www.xyzabc.com\\\"></iframe>\"\n"
"ink = \"<iframe src=\\\"http://www.xyzabc.com\\\" id='fram-1'></iframe>\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.