package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img.*?src=\\"(.+?)\\"`)
var str = `ink = "<a href=\"https://www.abc.gov/asd/asdfg/bill/bill-a\">H.R.11461</a>"
ink = "<a href=\"https://www.abc.gov/asd/asdfg/bill/bill-b\">H.R.11461</a>"
ink = "<img class='image-small' src=\"https://www.abc.gov/asd/asdfg/bill/bill-a\">"
ink = "<img class='image-large' src=\"https://www.abc.gov/asd/asdfg/bill/bill-b\" id='image'>"
ink = "<iframe class='ifram' src=\"http://www.xyzabc.com\"></iframe>"
ink = "<iframe src=\"http://www.xyzabc.com\" id='fram-1'></iframe>"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}