# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[\[{,:\]}]+[\[{,:\]}\s]*"(*SKIP)(*FAIL)|"(?!\s*[\[{,:\]}]))/\\$0/gm;t' <<< "{\"Equipment Contents\":[\"XL APPEARANCE GROUP\",\"body-color grille\",\"body-color body-side molding with chrome insert\",\"luggage rack\",\"15\" deep-dish cast aluminum wheels\",\"P235/75R15SL all-terrain OWL tires\",\"power door locks\",\"power windows\",\"p
ower mirrors\",\"cloth captains chairs\"]}"