import Foundation
let pattern = #"(?:[\[{,:\]}]+[\[{,:\]}\s]*"(*SKIP)(*FAIL)|"(?!\s*[\[{,:\]}]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"Equipment Contents":["XL APPEARANCE GROUP","body-color grille","body-color body-side molding with chrome insert","luggage rack","15" deep-dish cast aluminum wheels","P235/75R15SL all-terrain OWL tires","power door locks","power windows","p
ower mirrors","cloth captains chairs"]}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)