# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[\[{,:\]}]+[\[{,:\]}\s]*\"(*SKIP)(*FAIL)|\"(?!\s*[\[{,:\]}]))"
test_str = ("{\"Equipment Contents\":[\"XL APPEARANCE GROUP\",\"body-color grille\",\"body-color body-side molding with chrome insert\",\"luggage rack\",\"15\" deep-dish cast aluminum wheels\",\"P235/75R15SL all-terrain OWL tires\",\"power door locks\",\"power windows\",\"p\n"
"ower mirrors\",\"cloth captains chairs\"]}")
subst = "\\\\$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.